Delay in leads csv download
Incident Report for Unbounce
Resolved
The leads csv downloads are caught up by now, you should be receiving your leads csv download e-mails now. Please note that if your client contains a large amount of pages and leads, then it might take a bit longer to receive the leads csv download e-mail.

Also, if you've previously clicked on the 'leads csv download' button and didn't receive the download e-mail yet then please don't click on the button again as we're still processing the leads csv export and you should receive the download e-mail soon.
Posted Nov 12, 2021 - 10:00 PST
Update
We are currently still investigating into the issue, more updates will follow.
Posted Nov 12, 2021 - 09:50 PST
Investigating
Unbounce is currently experiencing an issue where the leads csv download function is being delayed. Regular lead delivery is unaffected, only the leads csv download function is delayed. As a result, there will be a delay before you will receive your leads csv download e-mail.

We apologize for the inconvenience and are currently investigating the issue. Subscribe to this status page to receive notifications on updates as they are made available.
Posted Nov 12, 2021 - 09:13 PST
This incident affected: Web Application (app.unbounce.com).