Newly added domains not showing in 'Change URL' list
Incident Report for Unbounce
Resolved
The incident has been resolved. Newly added domains show up in the 'Change URL' list on the page overview again as usual.
Posted Mar 21, 2023 - 08:04 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 21, 2023 - 06:53 PDT
Investigating
Newly added domains are currently not showing up in the 'Change URL' list on the page overview, making it not possible to connect pages to newly added domains.

We are investigating into this issue.
Posted Mar 21, 2023 - 06:29 PDT
This incident affected: Web Application (app.unbounce.com).