Chat Support Currently Unavailable
Incident Report for Unbounce
Resolved
Our live chat is now available again, and functioning normally. Thank you for your patience while our third-party provider looked into this issue.
Posted Oct 22, 2019 - 11:02 PDT
Identified
We are experiencing issues with our third-party chat client, and Unbounce live chat support is currently unavailable. For support, please get in touch at support@unbounce.com, or give us a call at 1-888-515-9161.
Posted Oct 22, 2019 - 09:56 PDT
This incident affected: Support (Live Chat Support).