Domain SSL Certificates Provisioning Delayed
Incident Report for Unbounce
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 04, 2018 - 14:25 PDT
Investigating
Unbounce is currently experiencing a delay in provisioning SSL certificates for custom domains.

We are currently investigating this issue and are working to get it resolved as soon as possible. Subscribe to this status page to receive notifications on updates as they are made available.
Posted 3 months ago. Sep 01, 2018 - 11:48 PDT