Delay in Leads Appearing in Leads Table
Incident Report for Unbounce
Resolved
Lead delivery has caught up fully and is no longer delayed. This incident has been resolved.
Posted Jun 10, 2021 - 16:43 PDT
Monitoring
We are seeing leads beginning to catch up and are currently monitoring this process. We will follow up with another update once lead processing is fully up-to-date and no longer delayed.
Posted Jun 10, 2021 - 16:28 PDT
Investigating
Unbounce is currently experiencing an issue where lead data displayed in the “view leads” table is being delayed. There is no data loss as a result of this issue and leads are still being captured correctly. There will be a delay in this data being displayed on the page overview screen as well as potential delays in sending lead data to third party integrations.

We apologize for the inconvenience and are currently investigating the issue. Subscribe to this status page to receive notifications on updates as they are made available.
Posted Jun 10, 2021 - 15:45 PDT
This incident affected: Web Application (app.unbounce.com) and Third-Party Integrations.