Delay in Leads Delivered to Mailchimp

Incident Report for Unbounce

Resolved

This issue has now been resolved.

Any leads that came in during the incident have been processed and should now be visible in Mailchimp and any new leads pushed via the Mailchimp integration are being processed as per normal.

Thank you for your patience while we addressed this issue.
Posted Jul 08, 2025 - 15:32 PDT

Identified

Unbounce is currently experiencing a delay in delivering leads to Mailchimp. Lead data will still be delivered and is still being collected by Unbounce. Leads can be viewed in the view leads section of the page overview screen and can be exported as a csv file.

We are currently investigating this issue and are working to get it resolved as soon as possible. Subscribe to this status page to receive notifications on updates as they are made available.
Posted Jul 08, 2025 - 11:07 PDT
This incident affected: Third-Party Integrations.