Delay in Page Stats
Incident Report for Unbounce
Resolved
Page Stats are now caught up and back up to date. Thank you for your patience while we resolved this issue.
Posted Feb 03, 2024 - 14:36 PST
Monitoring
Page Stats are now in the process of recovering and we are continuing to monitor the result.
Posted Feb 03, 2024 - 14:15 PST
Update
We have identified the delay impacting Page Stats and are working to resolve it.
Posted Feb 03, 2024 - 13:21 PST
Investigating
We are currently investigate a delay in Page Stats that are impacting some customers.
Posted Feb 03, 2024 - 12:14 PST
This incident affected: Web Application (app.unbounce.com).