Leads delivery delayed
Incident Report for Unbounce
Resolved
This is now resolved. Leads are being delivered in real time and back-log has been recovered.
Posted 2 months ago. Jun 17, 2019 - 06:59 PDT
Monitoring
Due to the recent traffic spike, the leads system has a larger than normal backlog. Leads delivery is expected to be delayed as the backlog clears.

The leads system is healthy according to our metrics and we will be monitoring to ensure that the backlog clears as expected.
Posted 2 months ago. Jun 17, 2019 - 04:22 PDT
This incident affected: Third-Party Integrations.