Live ubpages.com Pages Not Loading

Incident Report for Unbounce

Resolved

The issue should now be resolved as we see traffic volumes have now returned to normal.
Posted Dec 14, 2025 - 23:45 PST

Monitoring

The resolution has been implemented and are seeing recovery. We will continue to monitor as the recovery propagates across the network.
Posted Dec 14, 2025 - 22:00 PST

Identified

Unbounce is currently experiencing an outage on ubpages.com. Visitors can be met with an error when trying to load a live page published to a ubpages.com domain. Other domains are unaffected.

If you're using an ubpages.com domain for a campaign then we would recommend pausing the campaign until the issue is resolved.

We have identified the issue and are currently working towards resolution.
Posted Dec 14, 2025 - 21:36 PST
This incident affected: Page Servers.