Delay in Page Stats
Incident Report for Unbounce
Resolved
This incident has been resolved.
Posted 26 days ago. Sep 24, 2019 - 15:37 PDT
Investigating
Unbounce is currently experiencing a delay in stats being displayed on the page overview screen. No data will be lost. Our developers are investigating and this space will be updated once we have more information.
Posted 26 days ago. Sep 24, 2019 - 11:33 PDT