Delay in Delivering Leads via Webhook

Incident Report for Unbounce

Resolved

This incident has been resolved. Our system has caught up with delivering all of the backlogged leads via Webhook. No lead data was lost.

Please feel free to reach out to our Support Team if you have any questions.
Posted Jun 09, 2025 - 15:50 PDT

Investigating

Unbounce is currently experiencing a delay in delivering leads via webhook. Lead data is still being collected(no data loss) and will still be delivered. Leads can be viewed in the view leads section of the page overview screen.

Subscribe to this status page to receive notifications on updates as they are made available.
Posted Jun 09, 2025 - 14:44 PDT
This incident affected: Third-Party Integrations.