Some users cannot see the left hand navigation for Clients they are invited to

Incident Report for Unbounce

Resolved

We found an issue with an update to the Unbounce App that was made earlier today and have reverted that change. All navigation and other functionality should now be working/displaying as per normal. Thank you for your patience while we investigated this issue.
Posted Jun 13, 2025 - 14:43 PDT

Investigating

We are currently investigating an issue where the Unbounce App's left hand navigation briefly loads and then disappears for users that are invitees on an account. Thank you for your patience while we investigate this issue.
Posted Jun 13, 2025 - 14:38 PDT
This incident affected: Web Application (app.unbounce.com).