New Domain SSL Certificate Provisioning Affected
Incident Report for Unbounce
Resolved
The incident has been resolved. Let's Encrypt is now fully operational, so SSL certificates should be provisioned as usual.

If SSL provisioning has failed for new domains added during this time, please retry the domain. If SSL continues to fail, please don't hesitate to reach out to us at support@unbounce.com.
Posted Jul 01, 2021 - 14:43 PDT
Monitoring
Our upstream certificate provider, Let's Encrypt, is experiencing an issue with SSL certificate issuance, so domains that are newly added to Unbounce may see a delay in receiving SSL certificates.

We will continue to monitor the status and provide updates as they come. If you would also like to follow along with the incident, feel free to check out the Let's Encrypt status page: https://letsencrypt.status.io/.
Posted Jul 01, 2021 - 14:14 PDT
This incident affected: SSL Certificate Provisioning.