Issues with Account Sign-ups
Incident Report for Unbounce
Resolved
Our third party service is back up to speed, and new account signups should now be working as expected. Thanks for your patience! If you encounter any issues, you can get in touch at support@unbounce.com.
Posted Apr 09, 2018 - 14:09 PDT
Investigating
We have been informed by the third-party system that manages new customer sign-ups that there may be problems or delays with creating new Unbounce accounts. We are being kept in the know of their progress with this and apologize for any inconvenience this may cause.
Posted Apr 09, 2018 - 12:39 PDT