Can't invite users
Incident Report for Unbounce
Resolved
Our developers deployed a fix for the issue.
Posted Mar 27, 2024 - 15:03 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 27, 2024 - 14:38 PDT
Investigating
Some users are seeing a blank red message when trying to invite new users. Our developers are investigating.
Posted Mar 27, 2024 - 14:24 PDT
This incident affected: Web Application (app.unbounce.com).