Unable to Connect Custom Domains

Incident Report for Unbounce

Resolved

This incident has been resolved. Custom domain registration is now operating as expected. Please feel free to reach out to our Support Team if you have any questions.
Posted Mar 04, 2026 - 16:32 PST

Monitoring

A fix has been implemented, and we are actively monitoring to ensure continued stability. Custom domain registration is now operating as expected.
Posted Mar 04, 2026 - 15:24 PST

Investigating

We are currently investigating issues with custom domain registration functionality due to a Cloudflare outage.
Posted Mar 04, 2026 - 10:33 PST
This incident affected: Third Party Providers.