App.unbounce.com pages list sporadically not loading

Incident Report for Unbounce

Resolved

This incident is now resolved. A fix was implemented and the intermittent issues have stopped. Please don't hesitate to reach out to our support team if you have any questions.
Posted Sep 03, 2025 - 13:09 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 03, 2025 - 10:32 PDT

Investigating

When visiting app.unbounce.com customers may experience intermittent issues with the page list not loading (showing up as blank). It's good to note that refreshing app.unbounce.com usually makes the page list show up again. Our developers are investigating and this space will be updated once we have more information.
Posted Sep 03, 2025 - 09:42 PDT
This incident affected: Web Application (app.unbounce.com).