Chat Support Currently Unavailable
Incident Report for Unbounce
Resolved
Our third-party chat client has resolved the issue and the chat service has resumed normal operation.
Posted about 2 months ago. Jul 02, 2019 - 08:43 PDT
Identified
We are experiencing issues with our third-party chat client, and Unbounce live chat support is currently unavailable. For support, please get in touch at support@unbounce.com, or give us a call at 1-888-515-9161.
Posted about 2 months ago. Jul 02, 2019 - 07:15 PDT
This incident affected: Support (Live Chat Support).