Chat Support Currently Unavailable
Incident Report for Unbounce
Resolved
Our third-party chat client is back on, and our live chat support is available again.
Posted 27 days ago. Nov 14, 2018 - 11:12 PST
Identified
We are experiencing issues with our third-party chat client, and Unbounce live chat support is currently unavailable. For support, please get in touch at support@unbounce.com, or give us a call at 1-888-515-9161.
Posted 27 days ago. Nov 14, 2018 - 10:47 PST
This incident affected: Support (Live Chat Support).