SSL Secured Pages are Not Loading Intermittently
Incident Report for Unbounce
Resolved
Our developers have deployed a fix for the identified servers that were experiencing SSL failures. Newly issued and recently renewed SSL certificates should be served correctly from all regions now that the issue has been resolved, and any campaigns that were paused due to this incident can be unpaused again.
Posted Jul 06, 2020 - 16:17 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2020 - 15:01 PDT
Update
Update: in addition to one of our edge locations in Europe, we found that another region in US East is affected. This intermittent error would only affect new domains.
Posted Jul 06, 2020 - 14:43 PDT
Identified
The issue has been identified, one of our edge locations in Europe is presenting issues with SSL certificates. A fix is being implemented.
Posted Jul 06, 2020 - 13:39 PDT
Investigating
Unbounce is currently experiencing an issue where SSL secured pages are not being served for some users. Unsecured (http) URLs are still functioning normally. We recommend pausing any PPC or email campaigns using https URLs until the issue is resolved.

We are currently investigating this issue and are working to get it resolved as soon as possible. Subscribe to this status page to receive notifications on updates as they are made available.
Posted Jul 06, 2020 - 12:35 PDT
This incident affected: SSL Certificate Provisioning.