Delay in Leads Appearing in Leads Table
Incident Report for Unbounce
Resolved
The incident is now resolved.
Posted Dec 10, 2021 - 14:19 PST
Monitoring
A fix for this issue has been implemented. Leads delivery, including 3rd party applications and email notifications should be functioning as expected now.

We're continuing the monitor the issue out of an abundance of caution, but all functionality should be as per normal. Thank you for your patience while we resolved this issue.
Posted Dec 10, 2021 - 10:39 PST
Update
We are continuing to work on a fix for this issue.
Posted Dec 10, 2021 - 08:48 PST
Identified
Our Devs have identified the cause of the issue and are working to get it resolved.

Customers with forms will experience a delay in leads until this is resolved, however, no data is being lost.
Posted Dec 10, 2021 - 07:52 PST
Investigating
Unbounce is currently experiencing an issue where lead data displayed in the “view leads” table is being delayed. There is no data loss as a result of this issue and leads are still being captured correctly. There will be a delay in this data being displayed on the page overview screen as well as potential delays in sending lead data to third party integrations.

We apologize for the inconvenience and are currently investigating the issue. Subscribe to this status page to receive notifications on updates as they are made available.
Posted Dec 10, 2021 - 06:11 PST
This incident affected: Web Application (app.unbounce.com) and Third-Party Integrations.