Chat Support Currently Unavailable
Incident Report for Unbounce
Resolved
Our third party chat provider is back up and running, and live chat is once again available through the Unbounce app! Thanks for your patience.
Posted 6 months ago. Jun 27, 2018 - 14:57 PDT
Identified
We are again experiencing issues with our third-party chat client, and Unbounce live chat support is currently unavailable. For support, please get in touch at support@unbounce.com, or give us a call at 1-888-515-9161.
Posted 6 months ago. Jun 27, 2018 - 13:22 PDT
This incident affected: Support (Live Chat Support).