Incorrect dates for leads.
Incident Report for Unbounce
Resolved
We were able to identify that this issue is only affecting our UI and it's related to a third-party library. We have decided to push-back this update. No leads are lost and the correct dates will be updated on the new year.

We are sorry for any inconvenience this may have caused. If you have any questions, don't hesitate to reach out to us (support@unbounce.com)

UPDATE: The issue has been fixed and all the dates should be showing correctly in the app at this point.
Posted Dec 30, 2019 - 15:29 PST
Identified
Our team was able to identified the issue and we are working on a fix now.
Posted Dec 30, 2019 - 13:51 PST
Investigating
We have identified that leads are coming in with an incorrect date, showing 2020 year. No data is being lost and the leads are not compromised.
Our development team is currently investigating and working on a solution.
Posted Dec 30, 2019 - 13:43 PST