Delay in Page Stats
Incident Report for Unbounce
Resolved
This incident has been resolved and all delayed stats have caught up.
Please feel free to reach out if you have any questions or concerns.
Posted Jun 27, 2024 - 12:22 PDT
Monitoring
A fix has been implemented and most delayed stats are catching up. We'll be monitoring the progress and share an update again when they have all caught up.
Posted Jun 27, 2024 - 11:37 PDT
Investigating
Unbounce is currently experiencing a delay in stats being displayed on the page overview screen. No data will be lost. Our developers are investigating and this space will be updated once we have more information.
Posted Jun 27, 2024 - 11:28 PDT
This incident affected: Web Application (app.unbounce.com).