Issues Creating a New Unbounce Account Using Google Single Sign-On
Incident Report for Unbounce
Resolved
We've temporarily removed the ability to sign up for a new account using Google SSO. Once you have created an account with an email address and password, if you want to enable Google SSO, you can do so by following these steps: https://documentation.unbounce.com/hc/en-us/articles/360018397211-Using-Google-Single-Sign-On-SSO
Posted May 09, 2024 - 14:18 PDT
Investigating
We are currently investigating an issue where prospective customers are unable to complete the sign up process for a new Unbounce account when using Google Single Sign-On (SSO).

If you are currently attempting to sign up, please create a new account using the email address/password option. Once your account is created, you can enable Google SSO following these steps: https://documentation.unbounce.com/hc/en-us/articles/360018397211-Using-Google-Single-Sign-On-SSO
Posted May 09, 2024 - 13:15 PDT
This incident affected: Web Application (app.unbounce.com).