Chat and Phone Support Currently Unavailable
Incident Report for Unbounce
Resolved
This incident has been resolved. Live chat and phone support is now available.
Posted Sep 21, 2020 - 10:12 PDT
Identified
We are experiencing issues with our third-party chat and phone client, and Unbounce live chat and phone support is currently unavailable. For support, please get in touch at with us through email at support@unbounce.com.
Posted Sep 21, 2020 - 09:46 PDT
This incident affected: Support (Live Chat Support, Live Phone Support).