Unbounce Support Live Channel Outage
Incident Report for Unbounce
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 08:39 PST
Investigating
We are currently experiencing an outage on both our live chat and phone support channels due to an outage with our third party service platform. If you need support immediately please email support@unbounce.com and we will get back to you as soon as we can.
Posted Dec 15, 2021 - 08:09 PST
This incident affected: Support (Live Chat Support, Live Phone Support).