Delay in Page Stats
Incident Report for Unbounce
Resolved
This incident has been resolved. The delay has caught up. The stats delayed on the page overview screen should be up to date.
Posted Apr 07, 2021 - 14:26 PDT
Identified
Unbounce is currently experiencing a delay in stats being displayed on the page overview screen. No data will be lost. Our developers are investigating and this space will be updated once we have more information.
Posted Apr 07, 2021 - 14:20 PDT
This incident affected: Web Application (app.unbounce.com).