Issues with In-App Cancellation Requests

Incident Report for Unbounce

Resolved

In-App Cancellations are fully functional.
Posted Feb 20, 2026 - 08:38 PST

Investigating

We are currently investigating our in-app cancellation requests being blocked by an external form error. Please contact our support team at https://unbounce.com/contact-us/support/ to have cancellations manually processed.
Posted Feb 20, 2026 - 08:11 PST
This incident affected: Web Application (app.unbounce.com).