Support Live Chat - Potential Issues
Incident Report for Unbounce
Resolved
We believe this issue has now been resolved after an update from our 3rd party chat provider.
Posted 3 months ago. Jul 17, 2019 - 09:38 PDT
Investigating
We are investigating a few reports of issues connecting with our team via live chat. If you are currently unable to see the Get In Touch option from our help widget, please email us at support@unbounce.com and we'll get back to you via email as soon as possible.
Posted 3 months ago. Jul 17, 2019 - 03:00 PDT
This incident affected: Support (Live Chat Support).