Email Notification Deliverability Issues
Incident Report for Unbounce
Resolved
Our email deliverability is back to it's pre-incident rate and we're confident that a regular rate of notifications are reaching their intended email servers.

If email notifications from Unbounce had started being filtered to your junk/spam, you may still see them being filtered there, instead of your inbox. However, if you whitelist notifications@unbounce.com, support@unbounce.com, and our IP (208.117.48.234), the issue should be resolved going forward.

For Outlook customers, if you are still seeing email filtered to Outlook's quarantine, please try the steps above. If that doesn't solve the issue, your Outlook admin can also take the following steps which should solve the issue for everyone in your organization:
1. log into exchange admin center, go to protection> spam filter.
2. on the general page, double-click the default policy in order to start editing it.
3. navigate to allow lists> sender allow lists. click add, and then in the selection dialog box, add the Unbounce email addresses. click ok to return to the allow lists page.

Thank you for your patience while we worked on this issue with our 3rd party provider. If we can help with this or anything else, please don't hesitate to reach out to us via Support by clicking on the question mark (?) in the top right corner of the Unbounce app.
Posted Apr 03, 2024 - 16:35 PDT
Update
We are continuing to work with our 3rd party email provider to improve our deliverability.

At this time, the vast majority of our emails are reaching recipient mail servers, however, some may still be going to spam/junk folders or Outlook's quarantine.

If you are using a hosted version of Outlook (you manage your server vs. logging in via Outlook.com), your email notifications may be in Outlook's quarantine. These emails from notifications@unbounce.com can be released from Outlook's quarantine by following these steps: https://learn.microsoft.com/en-us/microsoft-365/security/office-365-security/quarantine-end-user?view=o365-worldwide#release-quarantined-email.

We became aware that some recipient Outlook.com, Hotmail.com, and Live.com email addresses were blocking Unbounce email notifications. Microsoft has now removed us from their block list and those emails have started to be delivered as per normal. They have informed us that it may be an additional 24-48 hours before all delivery is back to normal.

Thank you for your continued patience as we work to resolve this issue fully.
Posted Mar 28, 2024 - 16:10 PDT
Identified
We've fixed the underlying issue that was causing our emails to be placed on spam/block lists and otherwise get rejected from receiving mail servers.

We continue to work with our 3rd party partner to ensure email reaches recipients inboxes reliably, however, email notifications should be reaching recipient email servers as of today, March 20th. If you are not seeing notifications in your inbox from today, please check your spam filter. If you are using Outlook, your email notifications may be in Outlook's quarantine. These emails from notifications@unbounce.com can be released from Outlook's quarantine by following these steps: https://learn.microsoft.com/en-us/microsoft-365/security/office-365-security/quarantine-end-user?view=o365-worldwide#release-quarantined-email.

Thank you for your patience. We'll update again once we're confident the majority of email is being delivered directly to customer inboxes.
Posted Mar 20, 2024 - 16:21 PDT
Investigating
We are currently investigating an issue where some customers are not receiving email notifications generated from within Unbounce, including, but not limited to Lead Notifications, Page Upload and Downloads, User Invitations.

If you are expecting notifications that you have not received, please check your spam filter. If you are using Outlook, your email notifications may be in Outlook's quarantine. These emails from notifications@unbounce.com can be released from Outlook's quarantine by following these steps: https://learn.microsoft.com/en-us/microsoft-365/security/office-365-security/quarantine-end-user?view=o365-worldwide#release-quarantined-email.

Thank you for your patience while we continue to investigate this issue.
Posted Mar 18, 2024 - 14:14 PDT
This incident affected: Web Application (app.unbounce.com).