Chat Support Currently Unavailable
Incident Report for Unbounce
Resolved
Our third party chat tool is back up and running, and Live Chat support is now available again. Thanks for your patience! If you have any questions, feel free to contact us at support@unbounce.com or 1.855.435.5151.
Posted Apr 19, 2018 - 16:44 PDT
Identified
We are experiencing issues with our third-party chat client, and Unbounce live chat support is currently unavailable. For support, please get in touch at support@unbounce.com, or give us a call at 1-888-515-9161.
Posted Apr 19, 2018 - 12:45 PDT