SSL Certificates Renewal Delayed
Incident Report for Unbounce
Resolved
The issue has been identified and we were able to fix and the issue should be resolved now.
Posted 7 months ago. Apr 08, 2019 - 09:06 PDT
Investigating
Unbounce is currently experiencing a delay in renewing SSL certificates for custom domains. SSL will still be enabled on domains after a delay.

We are currently investigating this issue and are working to get it resolved as soon as possible. Subscribe to this status page to receive notifications on updates as they are made available.
Posted 7 months ago. Apr 08, 2019 - 08:49 PDT
This incident affected: SSL Certificate Provisioning.