Newly Added Domains Stuck in "Configuring" State

Incident Report for Unbounce

Resolved

This incident has been resolved.
Posted Jul 22, 2025 - 04:51 PDT

Update

We have seen recovery of Let's Encrypt – the 3rd party SSL certificate provider we use.

All impacted domains have recovered. New custom domains may remain in a configuring state for longer than normal, as the 3rd party system recovers from the resulting high traffic volumes.
Posted Jul 21, 2025 - 21:25 PDT

Monitoring

We have identified that the issue is caused by Let's Encrypt – the 3rd party SSL certificate provider we use. They are currently experiencing an outage that affects how our domains get new SSL certificates. For more information on the outage, check out their status page: https://letsencrypt.status.io/.

We are monitoring the status of the Let's Encrypt outage and we'll be back with more updates at a later time.
Posted Jul 21, 2025 - 17:04 PDT

Investigating

Unbounce is currently experiencing an issue with configuring custom domains that have just been added. All existing domains are unaffected.

We are currently investigating this issue and are working to get it resolved as soon as possible. Subscribe to this status page to receive notifications on updates as they are made available.
Posted Jul 21, 2025 - 16:29 PDT
This incident affected: SSL Certificate Provisioning.