Can't Change Page URL or Add New Custom Domains
Incident Report for Unbounce
Resolved
We've isolated the underlying issue and applied a fix. All domain and URL functionality should be working as per normal. If you continue to see any issues or need assistance with anything else, please contact us via the Support widget in-app or support@unbounce.com.

Thank you for your patience while we investigated and resolved this issue.
Posted Jul 12, 2022 - 14:58 PDT
Investigating
We are currently investigating an issue where customers can't change page URLs of any pages on custom domains or add new custom domains.

Existing pages and custom domains are functioning normally and there are no other known issues at this time.

Thank you for your patience. We'll update here as soon as possible.
Posted Jul 12, 2022 - 14:52 PDT
This incident affected: Web Application (app.unbounce.com).