Elipsis Menu not available for a subset of customers
Incident Report for Unbounce
Resolved
The issue has been solved. All the customers should be able to access the elipsis menu on All Pages page.

If you have any questions, feel free to reach out to our support (support@unbounce.com).
Posted Dec 17, 2019 - 13:26 PST
Identified
The root cause of this issue has been found and we are now working on to fix.
Posted Dec 17, 2019 - 13:01 PST
Investigating
The Elipsis menu(https://screencast.com/t/wcjLvsLHBoy) is not available for a certain subset of customers.

Our team has identified the issue and is currently investigating.
Posted Dec 17, 2019 - 12:59 PST
This incident affected: Web Application (app.unbounce.com).