Cannot Delete Domains
Incident Report for Unbounce
Resolved
This incident has been resolved. Domains can now be deleted successfully.

Thank you for your patience! Please reach out to our Support Team if you have any questions.
Posted Mar 08, 2023 - 16:12 PST
Investigating
Unbounce is currently experiencing an issue with deleting domains. Domains can still be added and edited.

We are currently investigating this issue and are working to get it resolved as soon as possible. Subscribe to this status page to receive notifications on updates as they are made available.
Posted Mar 08, 2023 - 16:06 PST
This incident affected: Web Application (app.unbounce.com).