Billing information unavailable
Incident Report for Unbounce
Resolved
Our third-party payment processing provider has completed their maintenance. Unbounce users can now access and edit their billing information normally, and register for new 30-day Free Trials at unbounce.com/pricing

During this maintenance, published pages and content was not affected.
Posted 3 months ago. Sep 18, 2017 - 08:03 PDT
Identified
Currently, our third-party payment processing provider is performing maintenance, which will cause intermittent issues for Unbounce users. We will update this page as more information becomes available.

Some Unbounce users may be unable to view or update their billing information, and may not be able to register for 30-day Free Trials. If you wish to begin an Unbounce trial now, you can still use a Free Demo account by registering on this page here: https://app.unbounce.com/registrations/3e134523e02008d1/edit

This maintenance does not affect published content and pages, and you will still be able to build and publish content normally. If you have any questions, you can contact support@unbounce.com
Posted 3 months ago. Sep 18, 2017 - 07:01 PDT