Intermittent Errors around Domain SSL Certificates Renewal
Incident Report for Unbounce
Resolved
This issue around SSL certificate renewals failing for some custom domains has been resolved.
Posted Jul 16, 2020 - 18:01 PDT
Investigating
Unbounce is currently experiencing an intermittent issue renewing SSL certificates for some custom domains.

We are currently investigating this issue and are working to get it resolved as soon as possible. Subscribe to this status page to receive notifications on updates as they are made available.
Posted Jul 16, 2020 - 17:00 PDT
This incident affected: SSL Certificate Provisioning.