Inbound Email Support Not Available
Incident Report for Unbounce
Resolved
We've identified the issue and resolved it. Our inbound e-mail support is now fully functional again. If you are still experiencing issues with our e-mail ticketing system, please reach out to us via our in-app chat and we will address the problem directly.
Posted Mar 09, 2021 - 07:15 PST
Update
We are continuing to work on a fix for this issue.
Posted Mar 09, 2021 - 05:07 PST
Identified
Unbounce inbound e-mail support is not available due to a technical issue. If you need to contact our support team please use our in-app live chat. If no support agents are available to assist your contact information will be saved and we will reach out as soon as possible.
Posted Mar 09, 2021 - 02:43 PST
This incident affected: Support (Email Support).