Issues publishing pages.
Incident Report for Unbounce
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 14, 2018 - 15:09 PDT
Investigating
We are currently experiencing issues publishing pages. Our developers are currently investigating this issue and will provide an update shortly.
Posted 6 months ago. Jun 14, 2018 - 14:57 PDT
This incident affected: Web Application (app.unbounce.com).