Home Page Login
Incident Report for Unbounce
Resolved
This incident has now been resolved. Customers can now access the log in page from the Unbounce home page.
Posted Jan 05, 2022 - 19:53 PST
Update
We are continuing to investigate this issue.
Posted Jan 05, 2022 - 19:22 PST
Investigating
We are currently experiencing issues with users logging in from the Unbounce home page. Users can continue to login using the following link: app.unbounce.com/users/sign_in
Posted Jan 05, 2022 - 19:18 PST
This incident affected: Main Web Site and Blog (unbounce.com).