Traffic stats are delayed
Incident Report for Unbounce
Resolved
Traffic stats have caught up, there should be no longer be delays.
Posted 5 months ago. Jun 17, 2017 - 17:47 PDT
Monitoring
Customer traffic stats are currently delayed. We have identified the cause, and are monitoring the system while it catches up.
Posted 5 months ago. Jun 17, 2017 - 16:21 PDT