Live chat support unavailable
Incident Report for Unbounce
Resolved
Our third party live chat provider has resolved their incident, and live chat is now available as usual. If you experience any trouble, feel free to let us know at support@unbounce.com, or at 1.855.435.5151. Thanks for your patience!
Posted 2 months ago. Jun 08, 2017 - 13:40 PDT
Monitoring
Our third-party live chat service is currently experiencing issues with delivering messages properly and live chat is currently unavailable. You are still able to contact Unbounce Support at 1.855.435.5151 or support@unbounce.com.
Posted 2 months ago. Jun 08, 2017 - 12:54 PDT