Client Traffic Report service is down
Incident Report for Unbounce
Resolved
The issue has been resolved.
Posted 3 months ago. Jun 13, 2017 - 23:20 PDT
Identified
Customers will not receive client traffic report. This is a temporary issue and our developers are currently working on fixing this issue.
Posted 3 months ago. Jun 13, 2017 - 22:07 PDT