Form Submissions delayed
Incident Report for Unbounce
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 10, 2017 - 18:55 PDT
Monitoring
We are currently receiving a high traffic of form submissions, expect some delays in storage and delivery
Posted about 1 month ago. Sep 10, 2017 - 16:40 PDT