Delay: Lead Notifications and Integrations
Incident Report for Unbounce
Resolved
This incident has been resolved.
Posted Nov 20, 2017 - 15:52 PST
Investigating
Unbounce is currently experiencing delays with lead notifications and in sending lead data to third party integrations. There is no data loss as a result of this issue.

We apologize for the inconvenience and are currently investigating the issue. Subscribe to this status page to receive notifications on updates as they are made available.
Posted Nov 20, 2017 - 14:39 PST