Email Delivery Delays
Incident Report for Unbounce
Resolved
Delayed email delivery is now resolved. No notifications should have been lost during this time, and should arrive safely in your inbox.
Thank you for your patience and if you have any questions please reach out to support@unbounce.com
Posted 5 months ago. Mar 09, 2017 - 23:08 PST
Identified
We are currently monitoring email delivery delays to some email providers. Thanks for your patience while we keep an eye on this.
If you have any questions please reach out at 1-888-515-9161 or support@unbounce.com
Posted 5 months ago. Mar 09, 2017 - 21:54 PST