Temporary Live Phone Support Change
Incident Report for Unbounce
Resolved
This incident has been resolved, and Phone Support is available as usual at 1.888.515.9161. If you experience any trouble, let us know via Live Chat in the Unbounce app, or at support@unbounce.com.
Posted 5 months ago. Mar 27, 2017 - 11:37 PDT
Identified
We're experiencing issues with our phone system, and our usual 1.888.515.9161 number is unavailable. Phone support is currently available at 1.855.435.5151, through chat support in the app, or at support@unbounce.com.
Posted 5 months ago. Mar 27, 2017 - 11:11 PDT