Leads .csv Report Not Exporting
Incident Report for Unbounce
Resolved
Our developers have identified and resolved the issue. Downloading .csv of leads at the page and client level are now operating as expected. This did not affect any leads that came in during this time. If you have any questions, you can contact Unbounce Support at support@unbounce.com.
Posted about 1 month ago. Sep 02, 2017 - 10:33 PDT
Investigating
Some customers are experiencing issues generating and downloading .csv of leads at page and client level. Our developers are currently investigating the issue.

We apologize for the inconvenience and will update this space with more information shortly! If you have any questions, you can contact Unbounce Support at support@unbounce.com
Posted about 1 month ago. Sep 02, 2017 - 09:44 PDT